Skip To Content

Which Windows versions support Rapid Insight products?

Rapid Insight products can be run on Windows desktop OS version 7 SP1 or later; or Windows Server OS version 2012 or later. 

This is because Construct and Predict rely on a .NET Framework 4.6.1, so the software can be run on any versions of Windows that are also supported editions of .Net Framework 4.6.1. 

Click here for a comprehensive list of Windows .NET Framework system requirements.

 

Back to Knowledge Base